Page 1 of 1

Help me, AFK Community! You're my only hope.

Posted: Sun Feb 14, 2016 10:53 pm
by BC_Goldman
Something hinky is going on with my computer. Ever since around the time KoL had that database problem, I'm having serious connection issues with KoL. I'll log in and sometimes in under 20 seconds, KoL simply disappears. Mafia stops working, attempting to navigate directly to kingdomofloathing.com results in a failure/timeout on Chrome, FF, and Edge. Pinging is successful with ~95 millisecond times. I seem to be able to connect ok using wifi on my phone for the most part but that's not practical for playing much even with my huge screen size. My internet is from connecting to an Xfinity wifi somewhere nearby.

The one other thing that comes to mind is around the same time as the database issue (probably slightly after?), I logged on with kolmafia and went into the kitchen to do something. When I came back, my computer was in the middle of resetting and installing an update which pissed me off because it's stupid that an update can just shut down and restart the computer because it feels like it. Once that finished, I was completely unable to connect to the internet. I could connect to the Xfinity wifi but couldn't reach anything. I rolled back the update but it didn't solve the problem. The next day I couldn't connect to the hotspot via my phone either and was told my account didn't have a high enough speed to be allowed access to Xfinity wifi. It went away after a day or two but I had to connect my computer to another network to get it to recognize the internet again. Once I did that, it started working on the Xfinity wifi again. Don't know if that's part of the problem or not. I have played KoL while connected to another wifi source once without problems but I don't know if that was a coincidence or not as sometimes I have few/no issues on the xfinity wifi but when there are problems they are major and seem to occur more often than not.

What I know so far:
Problem seems to be specific to my computer.
It is browser agnostic
does not affect directly pinging kingdomofloathing.com from command prompt
can sometimes be temporarily fixed by turning my computer's wifi on and off
KoL (and mafia by extension) is the only website I seem to have trouble with
I don't think it's an add-on conflict since I don't have any on Edge or FF. Downloaded FF tonight just to try from another browser.

If I can't solve this problem, I don't think I can keep playing KoL and that would be a bummer. Does anyone have ideas I can try?

Re: Help me, AFK Community! You're my only hope.

Posted: Sun Feb 14, 2016 11:02 pm
by lostcalpolydude
Do things work if you connect directly to http://69.16.150.211/ ? Mafia has an option on the Connection tab to Use IP address, though I think you need to check that every time.

Re: Help me, AFK Community! You're my only hope.

Posted: Wed Feb 17, 2016 7:40 pm
by BC_Goldman
When KoL doesn't come up, using the IP address doesn't work either. I tried again after you posted that suggestion. On the plus side, yesterday and today there were no issues playing. Fingers crossed that the problem worked itself out.

Re: Help me, AFK Community! You're my only hope.

Posted: Mon Mar 07, 2016 5:25 pm
by BC_Goldman
Problem still crops up from time to time. It appears that moving from my living room to my bedroom can solve the problem. Since I'm connecting to the internet over xfinity wifi connections (and there are a ton of them visible to me) I'm wondering if there's something on one of the routers that is causing KoL to be unable to load and moving to a different spot ends up with me connecting via a different router.

Another possibility is there are too many wifi signals in my living room and it hampers connections somehow but not for other sites.

Edit: Just used a wifi-scanning app on my phone and it sees 19 xfinity wifi signals and a bunch of other networks.

Re: Help me, AFK Community! You're my only hope.

Posted: Tue Mar 08, 2016 10:18 am
by lostcalpolydude
For what it's worth, I often can't connect to KoL using Comcast at work (and my work place doesn't filter out sites). My connection at home (also Comcast, like 5 miles away) doesn't have that issue.

If we didn't have government enforced monopolies for internet service, I would suggest ditching Comcast.

Re: Help me, AFK Community! You're my only hope.

Posted: Mon Apr 04, 2016 9:45 pm
by BC_Goldman
I would love an alternative to Comcast!

Updates: Phazic and I were experimenting tonight using telnet. Unfortunately, once I finally figured out how to work it, the connection started working again so I can't test telnet results. If I didn't note this before, the browser error is for a connection reset (eventually) after just spinning for a while.

Having the laptop in the bedroom is fairly good at solving the problem. Connections are lower strength but I can usually keep a connection to KoL. Sometimes still get the one that won't connect but shifting laptop to face another direction usually solves the problem.

Re: Help me, AFK Community! You're my only hope.

Posted: Wed Apr 06, 2016 10:35 am
by BC_Goldman
Noticed last night that this could somehow be connected to mafia. No idea how, but I did realize that if I lose connectivity it seems to stay that way. vanilla and mafia connections don't work. I can attempt multiple times to connect without success but as soon as I close down mafia the vanilla page starts working again. Something else had made me wonder if it was chat-related as I don't know that the problem typically occurs if I don't use the right side chat lane in relay browser so I switched back to older chat in the relay browser to see if that makes a difference. Will post more info if I can figure anything out.

I don't think this is mafia problem as much as some kind of reaction between this one specific router and something in lol or mafia.

Other testing would be to play using vanilla kol (ugh) with modern chat if it turns out older chat while on mafia doesn't cause problems.

Re: Help me, AFK Community! You're my only hope.

Posted: Mon Apr 25, 2016 10:40 pm
by BC_Goldman
Using old chat seemed to fix the problem. Further testing appears to be moot as the new https login for kol may have solved the problem. I've been playing with modern chat since about a day after the switch and haven't had any issues yet.

Re: Help me, AFK Community! You're my only hope.

Posted: Tue Apr 26, 2016 2:49 pm
by lostcalpolydude
The server is hosted in a completely different location now, so Comcast's stupid routing issues were probably resolved by that.